SP1 won't install - Digital Website

Go to content

Main menu:

Computer science > Windows7 problems
 

Windows 7: Service Pack 1 (SP1) won't install. Error code 0x80070490.


When you just did install a fresh windows7 installation and after some updates, the windows7 SP1 won't install and give you the following error: (Err 0x80070490) then it means you've trouble with an driver who isn't correct installed!
There are a lot of solutions on the internet for this problem, but few are working. Below you can find a solution who's working, well at mine system it was working.

Solution:

  • Open the following file: => c:\windows\inf\setupapi.dev.log

  • Now search on this page ( Ctrl+F) for a text like Failed to find driver update or some words from it like failed. Here you see an example from what I did found, your will be probally deffirent, but the method is the same!


\usbport.inf_amd64_neutral_c170a336b4400414\usbport.inf' ([strings])
    inf: Opened INF: 'C:\Windows\System32\DriverStore\FileRepository\usb.inf_amd64_neutral_09ae23760eb5a304\usb.inf' ([strings])
    inf: Opened INF: 'C:\Windows\System32\DriverStore\FileRepository\cdrom.inf_amd64_neutral_c92d34b80b393423\cdrom.inf' ([strings])
!!!  sto:
Failed to find driver update 'C:\Windows\WinSxS\amd64_iastorv.inf_31bf3856ad364e35_6.1.7600.20667_none_0ba78522ba84961a\iastorv.inf' in Driver Store. Error = 0x00000490
<<<  Section end 2013/04/06 21:14:05.698
<<<  [Exit status: FAILURE(0x00000490)]

  • Copy that path with error you find in your log file! (this is lightgray marked in mine example!) Just highlight it with the mouse and copy.

  • Click "Start" => "All programs" => "Bureau Accessoires" and go with the mouse over the "Command prompt", press now right button and select "Run as administrator". Click yes.

  • At the command prompt type: pnputil -a and copy paste your error on it and ENTER! Mine example you see here => pnputil -a C:\Windows\WinSxS\amd64_iastorv.inf_31bf3856ad364e35_6.1.7600.20667_none_0ba78522ba84961a\iastorv.inf

  • You will see now "Windows security dialog box. Choose install this driver software anyway wait a moment until pnputil has stopped working. You will see something like: "Number succesfully imported: 1".


This was the solution for this problem. I did run the update again, and did install SP1 succesfull.

It can be, that you have more drivers that are failed! Check your log file and do the same steps as above!


The same solution can also be found here:

 

Back to content | Back to main menu